diff options
author | Nicholas Junge <nicholas.junge@web.de> | 2023-12-13 15:26:15 +0100 |
---|---|---|
committer | GitHub <noreply@github.com> | 2023-12-13 14:26:15 +0000 |
commit | c2de5261302fa307ebe06b24c0fc30653bed5e17 (patch) | |
tree | 92685c2f2b635610d8d39e826cb58879cc5f9872 /setup.py | |
parent | 754ef08ab91767be54f56e8de3f00527aef3f779 (diff) | |
download | google-benchmark-c2de5261302fa307ebe06b24c0fc30653bed5e17.tar.gz google-benchmark-c2de5261302fa307ebe06b24c0fc30653bed5e17.zip |
Run `pre-commit autoupdate`, fix stale pyproject.toml comments (#1712)
* Run `pre-commit autoupdate`, fix stale pyproject.toml comments
* Set `--enable_bzlmod=false` for the moment
Until the newer nanobind tags are pushed to the BCR, it's best to disable
bzlmod for the bindings, because the Python CI breaks due to Bazel 7
enabling bzlmod by default.
* Remove E203 ignore, add linebreaks to semantically group ruff options
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 1 |
1 files changed, 1 insertions, 0 deletions
@@ -74,6 +74,7 @@ class BuildBazelExtension(build_ext.build_ext): "bazel", "build", ext.bazel_target, + "--enable_bzlmod=false", f"--symlink_prefix={temp_path / 'bazel-'}", f"--compilation_mode={'dbg' if self.debug else 'opt'}", # C++17 is required by nanobind |