aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml25
1 files changed, 8 insertions, 17 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 62507a8..14f173f 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,25 +1,21 @@
[build-system]
-requires = ["setuptools", "setuptools-scm[toml]", "wheel"]
+requires = ["setuptools<73"]
build-backend = "setuptools.build_meta"
[project]
name = "google_benchmark"
description = "A library to benchmark code snippets."
-requires-python = ">=3.8"
-license = {file = "LICENSE"}
+requires-python = ">=3.10"
+license = { file = "LICENSE" }
keywords = ["benchmark"]
-authors = [
- {name = "Google", email = "benchmark-discuss@googlegroups.com"},
-]
+authors = [{ name = "Google", email = "benchmark-discuss@googlegroups.com" }]
classifiers = [
"Development Status :: 4 - Beta",
"Intended Audience :: Developers",
"Intended Audience :: Science/Research",
"License :: OSI Approved :: Apache Software License",
- "Programming Language :: Python :: 3.8",
- "Programming Language :: Python :: 3.9",
"Programming Language :: Python :: 3.10",
"Programming Language :: Python :: 3.11",
"Programming Language :: Python :: 3.12",
@@ -29,14 +25,10 @@ classifiers = [
dynamic = ["readme", "version"]
-dependencies = [
- "absl-py>=0.7.1",
-]
+dependencies = ["absl-py>=0.7.1"]
[project.optional-dependencies]
-dev = [
- "pre-commit>=3.3.3",
-]
+dev = ["pre-commit>=3.3.3"]
[project.urls]
Homepage = "https://github.com/google/benchmark"
@@ -45,7 +37,7 @@ Repository = "https://github.com/google/benchmark.git"
Discord = "https://discord.gg/cz7UX7wKC2"
[tool.setuptools]
-package-dir = {"" = "bindings/python"}
+package-dir = { "" = "bindings/python" }
zip-safe = false
[tool.setuptools.packages.find]
@@ -53,8 +45,7 @@ where = ["bindings/python"]
[tool.setuptools.dynamic]
readme = { file = "README.md", content-type = "text/markdown" }
-
-[tool.setuptools_scm]
+version = { attr = "google_benchmark.__version__" }
[tool.mypy]
check_untyped_defs = true