aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDaniel Gustafsson <dgustafsson@postgresql.org>2025-02-06 20:26:46 +0100
committerDaniel Gustafsson <dgustafsson@postgresql.org>2025-02-06 20:26:46 +0100
commit44ec09575145e908be8130de701e5c83995d1abe (patch)
treea846231e9979226bcf5209862ac37867954c89f9 /configure.ac
parent527f8fec220b4c3b84d353543e9741b76d396a11 (diff)
downloadpostgresql-44ec09575145e908be8130de701e5c83995d1abe.tar.gz
postgresql-44ec09575145e908be8130de701e5c83995d1abe.zip
Remove support for linking with libeay32 and ssleay32
The OpenSSL project stopped using the eay names back in 2016 on platforms other than Microsoft Windows, and version 1.1.0 removed the names from Windows as well. Since we now require OpenSSL 1.1.1 we can remove support for using the eay names from our tree as well. Author: Daniel Gustafsson <daniel@yesql.se> Reviewed-by: Michael Paquier <michael@paquier.xyz> Discussion: https://postgr.es/m/3C445F8E-D43E-4970-9CD9-A54882197714@yesql.se Discussion: https://postgr.es/m/CAHrt6656W9OnFomQTHBGYDcM5CKZ7hcgzFt8L+N0ezBZfcN3zA@mail.gmail.com
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 2 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index d713360f340..f56681e0d91 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1322,13 +1322,8 @@ if test "$with_ssl" = openssl ; then
# Minimum required OpenSSL version is 1.1.1
AC_DEFINE(OPENSSL_API_COMPAT, [0x10101000L],
[Define to the OpenSSL API version in use. This avoids deprecation warnings from newer OpenSSL versions.])
- if test "$PORTNAME" != "win32"; then
- AC_CHECK_LIB(crypto, CRYPTO_new_ex_data, [], [AC_MSG_ERROR([library 'crypto' is required for OpenSSL])])
- AC_CHECK_LIB(ssl, SSL_new, [], [AC_MSG_ERROR([library 'ssl' is required for OpenSSL])])
- else
- AC_SEARCH_LIBS(CRYPTO_new_ex_data, [eay32 crypto], [], [AC_MSG_ERROR([library 'eay32' or 'crypto' is required for OpenSSL])])
- AC_SEARCH_LIBS(SSL_new, [ssleay32 ssl], [], [AC_MSG_ERROR([library 'ssleay32' or 'ssl' is required for OpenSSL])])
- fi
+ AC_CHECK_LIB(crypto, CRYPTO_new_ex_data, [], [AC_MSG_ERROR([library 'crypto' is required for OpenSSL])])
+ AC_CHECK_LIB(ssl, SSL_new, [], [AC_MSG_ERROR([library 'ssl' is required for OpenSSL])])
# Functions introduced in OpenSSL 1.1.1.
AC_CHECK_FUNCS([SSL_CTX_set_ciphersuites], [], [AC_MSG_ERROR([OpenSSL version >= 1.1.1 is required for SSL support])])
# Function introduced in OpenSSL 1.0.2, not in LibreSSL.