aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Munro <tmunro@postgresql.org>2024-07-30 21:52:46 +1200
committerThomas Munro <tmunro@postgresql.org>2024-07-30 22:58:57 +1200
commit81385261362962deb9861b39b509aeffe213721d (patch)
treecf15fa763cea6ccbc200c5e60759a3688dfba118 /configure.ac
parente25626677f8076eb3ce94586136c5464ee154381 (diff)
downloadpostgresql-81385261362962deb9861b39b509aeffe213721d.tar.gz
postgresql-81385261362962deb9861b39b509aeffe213721d.zip
Remove --disable-atomics, require 32 bit atomics.
Modern versions of all relevant architectures and tool chains have atomics support. Since edadeb07, there is no remaining reason to carry code that simulates atomic flags and uint32 imperfectly with spinlocks. 64 bit atomics are still emulated with spinlocks, if needed, for now. Any modern compiler capable of implementing C11 <stdatomic.h> must have the underlying operations we need, though we don't require C11 yet. We detect certain compilers and architectures, so hypothetical new systems might need adjustments here. Reviewed-by: Heikki Linnakangas <hlinnaka@iki.fi> Reviewed-by: Tom Lane <tgl@sss.pgh.pa.us> (concept, not the patch) Reviewed-by: Andres Freund <andres@anarazel.de> (concept, not the patch) Discussion: https://postgr.es/m/3351991.1697728588%40sss.pgh.pa.us
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 0 insertions, 13 deletions
diff --git a/configure.ac b/configure.ac
index a72169f5745..75b73532fe0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -187,12 +187,6 @@ PGAC_ARG_BOOL(enable, rpath, yes,
AC_SUBST(enable_rpath)
#
-# Atomic operations
-#
-PGAC_ARG_BOOL(enable, atomics, yes,
- [do not use atomic operations])
-
-#
# --enable-debug adds -g to compiler flags
#
PGAC_ARG_BOOL(enable, debug, no,
@@ -1290,13 +1284,6 @@ failure. It is possible the compiler isn't looking in the proper directory.
Use --without-zlib to disable zlib support.])])
fi
-if test "$enable_atomics" = yes; then
- AC_DEFINE(HAVE_ATOMICS, 1, [Define to 1 if you want to use atomics if available.])
-else
- AC_MSG_WARN([
-*** Not using atomic operations will cause poor performance.])
-fi
-
if test "$with_gssapi" = yes ; then
if test "$PORTNAME" != "win32"; then
AC_SEARCH_LIBS(gss_store_cred_into, [gssapi_krb5 gss 'gssapi -lkrb5 -lcrypto'], [],