aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPeter Eisentraut <peter@eisentraut.org>2024-10-01 05:05:51 -0400
committerPeter Eisentraut <peter@eisentraut.org>2024-10-01 06:10:15 -0400
commitee4859123e3d47aef8cfe078f7faee2ebcecb613 (patch)
tree9fe243917dd9ee551b661c669384c5b5d2909fb3 /configure.ac
parent972c2cd2882b6dd7a2059d030d03e89dae47ede7 (diff)
downloadpostgresql-ee4859123e3d47aef8cfe078f7faee2ebcecb613.tar.gz
postgresql-ee4859123e3d47aef8cfe078f7faee2ebcecb613.zip
jit: Use opaque pointers in all supported LLVM versions.
LLVM's opaque pointer change began in LLVM 14, but remained optional until LLVM 16. When commit 37d5babb added opaque pointer support, we didn't turn it on for LLVM 14 and 15 yet because we didn't want to risk weird bitcode incompatibility problems in released branches of PostgreSQL. (That might have been overly cautious, I don't know.) Now that PostgreSQL 18 has dropped support for LLVM versions < 14, and since it hasn't been released yet and no extensions or bitcode have been built against it in the wild yet, we can be more aggressive. We can rip out the support code and build system clutter that made opaque pointer use optional. Author: Thomas Munro <thomas.munro@gmail.com> Reviewed-by: Peter Eisentraut <peter@eisentraut.org> Discussions: https://postgr.es/m/CA%2BhUKGLhNs5geZaVNj2EJ79Dx9W8fyWUU3HxcpZy55sMGcY%3DiA%40mail.gmail.com
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 0 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 6a35b2880bf..a7643476491 100644
--- a/configure.ac
+++ b/configure.ac
@@ -631,9 +631,6 @@ if test "$with_llvm" = yes ; then
PGAC_PROG_VARCC_VARFLAGS_OPT(CLANG, BITCODE_CFLAGS, [-fexcess-precision=standard])
PGAC_PROG_VARCXX_VARFLAGS_OPT(CLANGXX, BITCODE_CXXFLAGS, [-fexcess-precision=standard])
- PGAC_PROG_VARCC_VARFLAGS_OPT(CLANG, BITCODE_CFLAGS, [-Xclang -no-opaque-pointers])
- PGAC_PROG_VARCXX_VARFLAGS_OPT(CLANGXX, BITCODE_CXXFLAGS, [-Xclang -no-opaque-pointers])
-
NOT_THE_CFLAGS=""
PGAC_PROG_VARCC_VARFLAGS_OPT(CLANG, NOT_THE_CFLAGS, [-Wunused-command-line-argument])
if test -n "$NOT_THE_CFLAGS"; then