aboutsummaryrefslogtreecommitdiff
path: root/src/interfaces/python/setup.py
diff options
context:
space:
mode:
authorD'Arcy J.M. Cain <darcy@druid.net>2001-03-27 10:53:21 +0000
committerD'Arcy J.M. Cain <darcy@druid.net>2001-03-27 10:53:21 +0000
commitc4d354c271e405a48fab9cdaeb41b2d5bc177be0 (patch)
tree7cc846e51ae87a3b43b5ce95ca290bf749f69c4d /src/interfaces/python/setup.py
parentc252c972f6bdfa342552e146413cb26ec589af8f (diff)
downloadpostgresql-c4d354c271e405a48fab9cdaeb41b2d5bc177be0.tar.gz
postgresql-c4d354c271e405a48fab9cdaeb41b2d5bc177be0.zip
Add changes from Mikhail Terekhov <terekhov@emc.com>.
Use Extension method from distutils. Cleaned up mismatched indentation styles while I was at it.
Diffstat (limited to 'src/interfaces/python/setup.py')
-rwxr-xr-xsrc/interfaces/python/setup.py25
1 files changed, 13 insertions, 12 deletions
diff --git a/src/interfaces/python/setup.py b/src/interfaces/python/setup.py
index d1f15c67559..474808ec2a3 100755
--- a/src/interfaces/python/setup.py
+++ b/src/interfaces/python/setup.py
@@ -19,6 +19,7 @@
# on using distutils to install Python programs.
from distutils.core import setup
+from distutils.extension import Extension
import sys
if sys.platform == "win32":
@@ -35,21 +36,21 @@ else:
data_files = []
setup (name = "PyGreSQL",
- version = "3.1",
- description = "Python PostgreSQL Interfaces",
- author = "D'Arcy J. M. Cain",
- author_email = "darcy@druid.net",
- url = "http://www.druid.net/pygresql/",
- licence = "Python",
+ version = "3.1",
+ description = "Python PostgreSQL Interfaces",
+ author = "D'Arcy J. M. Cain",
+ author_email = "darcy@druid.net",
+ url = "http://www.druid.net/pygresql/",
+ licence = "Python",
py_modules = ['pg', 'pgdb'],
- ext_modules = [ Extension(
+ ext_modules = [ Extension(
name='_pg',
- 'sources': ['pgmodule.c'],
- 'include_dirs': include_dirs,
- 'library_dirs': library_dirs,
- 'libraries': optional_libs
- )]
+ sources = ['pgmodule.c'],
+ include_dirs = include_dirs,
+ library_dirs = library_dirs,
+ libraries = optional_libs
+ )]
data_files = data_files
)