aboutsummaryrefslogtreecommitdiff
path: root/src/interfaces/python/setup.py
diff options
context:
space:
mode:
authorBruce Momjian <bruce@momjian.us>2000-11-10 22:29:21 +0000
committerBruce Momjian <bruce@momjian.us>2000-11-10 22:29:21 +0000
commiteafb63643538000b3523478c3b2e51bd4611abbe (patch)
tree113fe0b7f8d35c474bd9d1a1a14a93ee7fbaee38 /src/interfaces/python/setup.py
parent960c18618486bf1815003d3ebe766f50a5fb2c55 (diff)
downloadpostgresql-eafb63643538000b3523478c3b2e51bd4611abbe.tar.gz
postgresql-eafb63643538000b3523478c3b2e51bd4611abbe.zip
Update to PyGreSQL 3.1:
Fix some quoting functions. In particular handle NULLs better. Use a method to add primary key information rather than direct manipulation of the class structures. Break decimal out in _quote (in pg.py) and treat it as float. Treat timestamp like date for quoting purposes. Remove a redundant SELECT from the get method speeding it, and insert since it calls get, up a little. Add test for BOOL type in typecast method to pgdbTypeCache class. (tv@beamnet.de) Fix pgdb.py to send port as integer to lower level function (dildog@l0pht.com) Change pg.py to speed up some operations Allow updates on tables with no primary keys. D'Arcy J.M. Cain
Diffstat (limited to 'src/interfaces/python/setup.py')
-rwxr-xr-xsrc/interfaces/python/setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/interfaces/python/setup.py b/src/interfaces/python/setup.py
index c128e6e7997..76c6cd1101f 100755
--- a/src/interfaces/python/setup.py
+++ b/src/interfaces/python/setup.py
@@ -24,7 +24,7 @@ optional_libs=['pq']
from distutils.core import setup
setup (name = "PyGreSQL",
- version = "3.0",
+ version = "3.1",
description = "Python PostgreSQL Interfaces",
author = "D'Arcy J. M. Cain",
author_email = "darcy@druid.net",