aboutsummaryrefslogtreecommitdiff
path: root/src/interfaces/python/setup.py
diff options
context:
space:
mode:
authorBruce Momjian <bruce@momjian.us>2000-10-02 03:27:33 +0000
committerBruce Momjian <bruce@momjian.us>2000-10-02 03:27:33 +0000
commitf36e7ff0927bdae6ea477cb64be9088307e5bddd (patch)
tree6eb269b322a01669c3a62d4a881c30ec05f80898 /src/interfaces/python/setup.py
parent0bd84442f55725ff073338dee5afc4cf895b747b (diff)
downloadpostgresql-f36e7ff0927bdae6ea477cb64be9088307e5bddd.tar.gz
postgresql-f36e7ff0927bdae6ea477cb64be9088307e5bddd.zip
Update for PyGreSQL 3.0, from D'Arcy J.M. Cain
Diffstat (limited to 'src/interfaces/python/setup.py')
-rwxr-xr-xsrc/interfaces/python/setup.py43
1 files changed, 43 insertions, 0 deletions
diff --git a/src/interfaces/python/setup.py b/src/interfaces/python/setup.py
new file mode 100755
index 00000000000..c128e6e7997
--- /dev/null
+++ b/src/interfaces/python/setup.py
@@ -0,0 +1,43 @@
+#!/usr/bin/env python
+
+include_dirs=['/usr/include/pgsql']
+library_dirs=['usr/lib/pgsql']
+optional_libs=['pq']
+
+# Setup script for the PyGreSQL version 3
+# created 2000/04 Mark Alexander <mwa@gate.net>
+# tweaked 2000/05 Jeremy Hylton <jeremy@cnri.reston.va.us>
+
+# requires distutils; standard in Python 1.6, otherwise download from
+# http://www.python.org/sigs/distutils-sig/download.html
+
+# You may have to change the first 3 variables (include_dirs,
+# library_dirs, optional_libs) to match your postgres distribution.
+
+# Now, you can:
+# python setup.py build # to build the module
+# python setup.py install # to install it
+
+# See http://www.python.org/sigs/distutils-sig/doc/ for more information
+# on using distutils to install Python programs.
+
+from distutils.core import setup
+
+setup (name = "PyGreSQL",
+ version = "3.0",
+ description = "Python PostgreSQL Interfaces",
+ author = "D'Arcy J. M. Cain",
+ author_email = "darcy@druid.net",
+ url = "http://www.druid.net/pygresql/",
+ licence = "Python",
+
+ py_modules = ['pg', 'pgdb'],
+ ext_modules = [ ('_pgmodule', {
+ 'sources': ['pgmodule.c'],
+ 'include_dirs': include_dirs,
+ 'library_dirs': library_dirs,
+ 'libraries': optional_libs
+ }
+ )]
+)
+